Bienvenue Invité, Pas encore membre ? Créer un compte  


Impossible de regler l'écran pour qu'il ne s'éteigne jamais

#1

Bonjour à tous,
J'ai reglé "économiseur d'écran '' sur: verrouillage de l'écran si inactif -- jamais. (je suis sous environnement X-cinnamon) rien à faire, l'écran s'éteint au bout de 10mn si je ne fais rien. C'est ennuyeux. Je suis débutant. Je suis sur Zorin Os 12.3.
Merci de m'aider.
virgil

Autrefois, il n'y avait que les catholiques qui nous emmerdaient, désormais ce sont les trois religions monothéistes. (Cabu)
Répondre en citant

#2

Bonjour Virgil, et bienvenue Sourire

Notre amis @roger  très habitué de l'interface graphique devrais te dire comment faire ça très facilement Clin d’oeil
S'il n'a pas la solution j'en ai une radicale qui fonctionne mais elle est plus compliqué à mettre en œuvre, on va donc peu être attendre une solution simple avant tout Sourire

Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.
Répondre en citant

#3

(24/04/2018, 22:23)virgil76 a écrit : Bonjour à tous,
J'ai reglé "économiseur d'écran '' sur: verrouillage de l'écran si inactif -- jamais. (je suis sous environnement X-cinnamon) rien à faire, l'écran s'éteint au bout de 10mn si je ne fais rien. C'est ennuyeux. Je suis débutant. Je suis sur Zorin Os 12.3.
Merci de m'aider.
virgil

Chez moi je n'ai pas mis à jour vers la 12.3

cette capture d'écran te montrera ce que j'ai comme réglages chez moi mais aussi te confirmera que si je n'ai pas d'activité pendant une bonne dizaine de mn, je suis obligé alors de " bouger " ma souris sur son tapis pour voir réapparaître mon espace de travail
 
[Image: verrouilageecran.png]

Je n'ai pas réussi à trouver une solution ( et pour cause dés que je branche mon pc, j'y passe des heures dessus et bien rare le moment où je suis inactif pendant plus de 5 mn ) car réellement je ne me suis jamais penché dessus.

Idée la seule chose qui eu pu sans doute m'être utile mais n'a jamais fonctionné chez moi car la fenêtre ne s'ouvre pas ( bug ) c'est ceci : la gestion d'énergie du pc ( dedans chercher à désactiver l'extinction de l'écran...). Si tu as cette option dans ton ZorinOS, essaies là pour voir si çà résolu ton soucis.
 
[Image: gestionalim.png]



Triste  J'ai toujours eu ce drôle de bug mais dans le fond pas si grave que cela car il suffit juste de bouger un poil sa souris pour retrouver son écran tel que nous l'avons laissé, après avoir piqué un gros roupillon pour cause de fatigue oculaire dans mon cas, et continuer comme si de rien n'était.

Idée  Autre petit avantage de cet " inconvénient mineur ", si quelqu'un passe devant ton pc et que tu n'as pas eu le temps de masquer ton travail ( sait on jamais sur quel genre de documents tu bossais Grand sourire ) cela a le mérite au moins de masquer celui ci laissant croire aux yeux indésirablement curieux que ton pc est fermé ...et que tu n'as rien à leur montrer Clin d’oeil

La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...
Répondre en citant

#4

(25/04/2018, 07:02)Mickael a écrit : S'il n'a pas la solution j'en ai une radicale qui fonctionne mais elle est plus compliqué à mettre en œuvre, on va donc peu être attendre une solution simple avant tout

Grand sourire  Moi je suis preneur de ta soluce, car toute les invites de commande, sudo & touti n'ont pas pu résoudre le problème que nous rencontrons de veille intempestive non désirée chez nous;
J'ai pourtant suivi pas mal de tutos chez Ubuntu pour Cinnamon ( notre interface graphique à tout les deux ) de même que sur le forum officiel de Zorin OS   mais n'ai vraiment rien trouvé pour m'aider ( il faut dire que mon Zorin à moi est ultra customisé donc possible que l'un de mes scripts fasse justement planter certaines choses dans ma version actuelle ) 

Flèche   https://zoringroup.com/forum/viewforum.php?f=3

La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...
Répondre en citant

#5

Tout d'abord on parle d'hibernation et de veille :
 La mise en veille et l'hibernation sont deux alternatives à l'arrêt de l'ordinateur.
  • La mise en veille permet d'économiser de l'énergie tout en gardant les applications ouvertes. Le réveil est très rapide. Il s'agit de ce que l'on appelle « suspend to ram » : toutes les informations de travail restent dans la mémoire vive et votre système d'exploitation se met en mode d'économie d'énergie. Par conséquent, une partie infime de la charge batterie est utilisée.
  • L'hibernation permet de sauvegarder l'état des applications sur le disque dur et ne consomme ensuite plus d'énergie. Le terme associé est « suspend to disk » et correspond à écrire toutes les données présentes dans la mémoire vive sur le disque dur avant d'arrêter complètement l'ordinateur. Au redémarrage, l'opération inverse est effectuée : on lit depuis le disque dur pour repeupler cette dernière. Cependant, cette opération est bien plus longue du fait de la lecture/écriture depuis le disque dur. Son avantage est qu'il n'y a absolument aucune consommation d'énergie en mode hibernation, une fois l'opération effectuée. Ce processus est connu sous Windows sous le nom de « veille prolongée »

Alors ma solution est un peu plus compliqué et reste à tester.

Ouvrir le terminal :

Entrer la commande :
Code :
sudo nano /etc/pm/sleep.d/000_no-hibernation

Pour empêcher la mise en hibernation :
Code :
#!/bin/sh
# Empêcher l'hibernation
. "$PM_FUNCTIONS"
[ "$1" = "hibernate" ] && inhibit || true

Pour empêcher la mise en hibernation et la mise en veille :
Code :
#!/bin/sh
# Empêcher l'hibernation et la veille

case "${1}" in
        suspend|hibernate)
                exit 1
                ;;
        resume|thaw)
                exit 0
                ;;
esac 

Enregistrer par Ctrl X puis O.

Un fois fait, alors fait un
Code :
sudo reboot

Pour redémarrer ton ordinateur, et dit moi ce que ça donne Clin d’oeil

Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.
Répondre en citant

#6
(Modification du message : 25/04/2018, 17:37 par roger.)

Timide  vu les termes employés et avec un historique des pages visitées dans mon navigateur j'ai remonté jusqu'à une page que j'avais suivi au tout début de mon installation zorin et après un changement de gestionnaire de bureau ;
En effet à cette époque et avant un premier crash de mon os ( relaté sur un autre forum mais ils ont enlevé tout mes sujets ) j'ai réussi tant bien que mal à récupérer mon zorin adoré mais au passage avais perdu l'usage du gestionnaire d'énergie ( bien que toujours présent dans mes réglages de config comme le montre ma capture d'écran plus haut ).

J'avais aussi ce problème de mise en veille ( je ne me sers jamais de " l'hibernation " car j'étais ou allume mon pc et puis c'est tout )  , donc il me fallait résoudre le fait que mon écran systématiquement au bout d'un certain temps se mettait en " veille " comme pour tout les bons vieux windows où je désactivais systématiquement cette fonction...

Revenons à nos moutons: mon historique de navigation m'a retourné un lien de page que j'ai reconnue de suite et c'est tout en bas de cette page que j'ai trouvé ce qui aurait pu sembler être mon bonheur pour " stopper définitivement cette mise en veille " avec un lien qu'il fallait suivre et taper dans une invite de commande en mode admin ( ce que j'ai fais )

Flèche  https://doc.ubuntu-fr.org/veille_et_hibernation

Le tout petit lien est déguisé sous ce terme
Code :
Pour empêcher la mise en veille et l'hibernation, utiliser ce code dans le fichier.

et bien entendu en cliquant sur le lien nous ouvrons une simple page ( https://launchpadlibrarian.net/58100042/...id_suspend )qui contient ceci
Code :
#!/bin/sh
# Avoid suspend #
# Copyright: Copyright (c) 2010 Paulo J. S. Silva
# License: GPL-2
#
case "${1}" in
        suspend|hibernate)
                exit 1
                ;;
        resume|thaw)
                exit 0
                ;;
esac

Confus Pour moi, cela n'a pas réglé mon soucis car si je reste toujours inactif pendant x minutes, l'écran se met aussitôt en veille ( tout noir ) et je suis donc obligé de bouger un peu ma souris pour que celui ci se rallume aussitôt sur la page ou le travail en cours sur mon pc.

Maintenant il faut aussi prendre en compte notre matériel je pense, car suivant une carte graphique, suivant la carte mère de notre UC etc le résultat n'est pas forcément négatif chez d'autres;

Donc si @virgil76  essaie lui aussi cette solution que tu proposes @Mickael peut être chez lui çà fonctionnera, mon avis n'est que par rapport à mon propre matériel et ma propre version de ZorinOS.

La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...
Répondre en citant

#7
Photo 

(25/04/2018, 14:09)roger a écrit :
(24/04/2018, 22:23)virgil76 a écrit : Bonjour,j’ai bien double cliqué sur ‘’Gestion d’alimentation’’ mais rien ne se passe. Moi, je dois aller dans ‘’économiseur d’écran’’ pour avoir cette capture d’écran (Roger). J’ai essayé la solution à ‘’Mickaël’’ mais c’est toujours la même chose. Au bout de 10mn d’inactivité … écran noir. Il faut que je bouge la souris pour que l’écran réapparaisse. Je vais chercher, chercher jusqu’à ce que je trouve. Je ne veux pas que mon écran s’éteigne.En tout cas merci pour vos réponse sympa et rapides. Je vous tiens au courant. Et si vous trouvez...Cordialement.virgil



Bonjour à tous,
J'ai reglé "économiseur d'écran '' sur: verrouillage de l'écran si inactif -- jamais. (je suis sous environnement X-cinnamon) rien à faire, l'écran s'éteint au bout de 10mn si je ne fais rien. C'est ennuyeux. Je suis débutant. Je suis sur Zorin Os 12.3.
Merci de m'aider.
virgil

Chez moi je n'ai pas mis à jour vers la 12.3

cette capture d'écran te montrera ce que j'ai comme réglages chez moi mais aussi te confirmera que si je n'ai pas d'activité pendant une bonne dizaine de mn, je suis obligé alors de " bouger " ma souris sur son tapis pour voir réapparaître mon espace de travail
 
[Image: verrouilageecran.png]

Je n'ai pas réussi à trouver une solution ( et pour cause dés que je branche mon pc, j'y passe des heures dessus et bien rare le moment où je suis inactif pendant plus de 5 mn ) car réellement je ne me suis jamais penché dessus.

Idée la seule chose qui eu pu sans doute m'être utile mais n'a jamais fonctionné chez moi car la fenêtre ne s'ouvre pas ( bug ) c'est ceci : la gestion d'énergie du pc ( dedans chercher à désactiver l'extinction de l'écran...). Si tu as cette option dans ton ZorinOS, essaies là pour voir si çà résolu ton soucis.
 
[Image: gestionalim.png]



Triste  J'ai toujours eu ce drôle de bug mais dans le fond pas si grave que cela car il suffit juste de bouger un poil sa souris pour retrouver son écran tel que nous l'avons laissé, après avoir piqué un gros roupillon pour cause de fatigue oculaire dans mon cas, et continuer comme si de rien n'était.

Idée  Autre petit avantage de cet " inconvénient mineur ", si quelqu'un passe devant ton pc et que tu n'as pas eu le temps de masquer ton travail ( sait on jamais sur quel genre de documents tu bossais Grand sourire ) cela a le mérite au moins de masquer celui ci laissant croire aux yeux indésirablement curieux que ton pc est fermé ...et que tu n'as rien à leur montrer Clin d’oeil   


Autrefois, il n'y avait que les catholiques qui nous emmerdaient, désormais ce sont les trois religions monothéistes. (Cabu)
Répondre en citant

#8

Je n'ai pas compris ta réponse @virgil76

@roger  ça marche ou ça marche pas ^^ j'ai pas compris non plus :p

Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.
Répondre en citant

#9

@Mickael  J'avais déjà essayé ta solution il y a quelques mois ( au début où j'ai installé zorin ) et cela n'avait pas marché du tout Triste

Je suis sur un pc tour, donc pour moi que j'économise la batterie n'a aucune importance car ma tour elle est sur secteur et avec 8GO de mémoire vive, je n'ai pas besoin de mettre en " hibernation " mon pc.

Flèche donc tant que je bosse sur mon pc, mon écran ne se met pas en veille

Flèche  si j'arrête de bosser sur le pc, et bien au bout de quelques minutes mon écran s'éteint

Flèche  si je regarde une longue vidéo sans rien faire du tout, mon écran reste allumé le temps que dure la vidéo.

Mon blème à moi et uniquement du au fait que si mon pc n'a pas une activité quelconque en cours, et bien il se met en état de veille tout seul.
drôle de comportement qui ne me gène pas trop vu que si je bouge ma souris, mon écran se rallume de suite sur la dernière fenêtre affichée.

Pour info, mon écran est une TV HD reconnu par zorin os Sourire
Pour moi ce n'est pas le problème de mettre en " hibernation " mon pc qui m'embête, mais simplement le fait que mon écran s'éteigne au bout de quelque minutes d'inactivité de mon pc.


@Mickael  , je pense que si tu n'as pas compris la réponse de notre ami vigil76 c'est normal, il n'en a pas fait à part cliquer sur " citer mon message " Clin d’oeil

La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...
Répondre en citant

#10

Bonjour,
j’ai bien double cliqué sur ‘’Gestion d’alimentation’’ mais rien ne se passe. Moi, je dois aller dans ‘’économiseur d’écran’’ pour avoir cette capture d’écran (Roger). J’ai essayé la solution à ‘’Mickaël’’ mais c’est toujours la même chose. Au bout de 10mn d’inactivité … écran noir. Il faut que je bouge la souris pour que l’écran réapparaisse. Je vais chercher, chercher jusqu’à ce que je trouve. Je ne veux pas que mon écran s’éteigne.En tout cas merci pour vos réponse sympa et rapides. Je vous tiens au courant. Et si vous trouvez...Cordialement.virgil

Autrefois, il n'y avait que les catholiques qui nous emmerdaient, désormais ce sont les trois religions monothéistes. (Cabu)
Répondre en citant




Utilisateur(s) parcourant ce sujet :
1 visiteur(s)



Réalisé par ZORIN OS .FR