refus d'installer un paquet

Vous voulez utiliser le terminal, mais vous ne savez pas comment faire ?
Répondre
francois
Membre confirmé
Messages : 5
Enregistré le : dim. 22 déc. 2019 20:54
 : Hors ligne

refus d'installer un paquet

Message par francois » lun. 6 janv. 2020 13:36

Bonjour

après un sudo apt-get upgrade , le message suivant s'affiche

"Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 wine-stable : Dépend: wine64 (>= 3.0-1zorin2) mais 2.0.2-1ubuntu1+zorin2 devra être installé ou
                        wine32 (>= 3.0-1zorin2)
E: Paquets défectueux"

qu'est ce que ça veut dire ?

Su quelqu'un à une idée merci d'avance !

 
0 "J'aime ce message"

Avatar du membre
Max77
Modérateur global
Messages : 99
Enregistré le : lun. 2 déc. 2019 18:01
Localisation : Seine et Marne
Nb de « J’aime » donnés: 4
Nb de « J’aime » reçus: 38
A été remercié : 12 fois
 : Hors ligne

Re: refus d'installer un paquet

Message par Max77 » lun. 6 janv. 2020 14:13

Bonjour francois​​​​​​​

Visiblement, tu essais d’installer Wine et les dépendances ne se sont pas satisfaites ?
Je te conseille d’utiliser Synaptic pour cela et de sélectionner :
Wine Stable 4.0.3+Zorin1
Installe aussi winetricks, cela entraîne l’installe de WineHQ
​​​​​​​
Synaptic règlera toutes les dépendances et tu ne devrais plus avoir de problème. 
0 "J'aime ce message"

Avatar du membre
jlb
Modérateur global
Messages : 341
Enregistré le : mer. 11 avr. 2018 08:31
Nb de « J’aime » donnés: 16
Nb de « J’aime » reçus: 53
A remercié : 19 fois
A été remercié : 26 fois
 : Hors ligne

Re: refus d'installer un paquet

Message par jlb » lun. 6 janv. 2020 14:29

francois a écrit :
lun. 6 janv. 2020 13:36
qu'est ce que ça veut dire ?
Bonjour @francois ! ;)
Oui, je connais : comme le système te le dit, tu demandes l'impossible et il t'explique ce qu'il faudrait faire pour mettre à jour wine-stable.
Il semblerait que les développeurs de Zorin 15 aient systématiquement personnalisé les composants logiciels de leur distribution (suffixe "zorin2"), ce qui peut bloquer les mises à jour vers les nouvelles versions disponibles chez Ubuntu.
J'ai découvert le problème à propos de la version de GIMP. La réponse que j'ai faite pourra peut-être te mettre sur la piste de ce qu'il faudrait faire pour résoudre le problème en installant les dépendances qui refusent de s'installer, ou mieux, la lecture de cet article qui m'a tout appris.
Mais franchement, je te conseillerais plutôt de supprimer complètement la version "Zorin" de wine-stable et d'installer la nouvelle version d'Ubuntu....
...ou de suivre le conseil que @Max77 t'a envoyé pendant que je rédigeais ma réponse.  :idea: ​​​​​​​ J'ai sans doute tort de trouver Synpatic plus rébarbatif et opaque que des lignes de commande.



 
0 "J'aime ce message"

Avatar du membre
Max77
Modérateur global
Messages : 99
Enregistré le : lun. 2 déc. 2019 18:01
Localisation : Seine et Marne
Nb de « J’aime » donnés: 4
Nb de « J’aime » reçus: 38
A été remercié : 12 fois
 : Hors ligne

Re: refus d'installer un paquet

Message par Max77 » lun. 6 janv. 2020 16:34

Pour compléter ma réponse rapide… après le message de @jlb  :)

Il se trouve que j’ai essayé d’installer la version stable de Wine en suivant la doc pour Ubuntu, mais l’installation ne fonctionnait pas correctement, pas mal de plantage dans les jeux, et je suis revenu à la solution que je te propose après avoir fait 5 ou 6 installations différentes de Wine, stable, staging et développement.

​​​​​​​Pour moi, seule la version Zorin fonctionne correctement sur Zorin et le plus simple est d'utiliser Synaptic pour ne pas avoir de souci !
0 "J'aime ce message"

Avatar du membre
Max77
Modérateur global
Messages : 99
Enregistré le : lun. 2 déc. 2019 18:01
Localisation : Seine et Marne
Nb de « J’aime » donnés: 4
Nb de « J’aime » reçus: 38
A été remercié : 12 fois
 : Hors ligne

Re: refus d'installer un paquet

Message par Max77 » lun. 6 janv. 2020 16:55

Image​​​​​​​
0 "J'aime ce message"

Avatar du membre
Mickael
Administrateur
Messages : 1012
Enregistré le : mar. 3 avr. 2018 21:27
Localisation : Ampuis
Nb de « J’aime » donnés: 24
Nb de « J’aime » reçus: 27
A remercié : 7 fois
A été remercié : 19 fois
Contact :
 : Hors ligne

Re: refus d'installer un paquet

Message par Mickael » mar. 7 janv. 2020 07:54

Bonjour,

Pour corriger les erreurs de dépendance tu peux faire un

code : Tout sélectionner

sudo apt autoremove

Cela devrai supprimer les dépendances non nécessaire.

Tu pourras ensuite faire :

code : Tout sélectionner

sudo apt full-upgrade
0 "J'aime ce message"
Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.

Avatar du membre
Max77
Modérateur global
Messages : 99
Enregistré le : lun. 2 déc. 2019 18:01
Localisation : Seine et Marne
Nb de « J’aime » donnés: 4
Nb de « J’aime » reçus: 38
A été remercié : 12 fois
 : Hors ligne

Re: refus d'installer un paquet

Message par Max77 » mar. 7 janv. 2020 08:19

C’est vrai, mais on peut faire la même chose avec Synaptic en s’affranchissant de la ligne de commande que j’aime bien, mais que je n’emploie que contraint et forcé.

On vante les mérites de Zorin sur ce forum en mettant en avant qu’il se rapproche de la simplicité de Windows pour les commandes, pourquoi ne pas mettre plus en avant cette application très puissante qui permet d‘installer, de désinstaller, de réparer, de mettre à jour et de supprimer les paquets obsolètes ? Mais il est vrai que nous sommes sur le sujet : Utilisation du Terminal !

​​​​​​​Mais comme dirait l’autre, ne n’est que mon avis :dodgy: .

On comprend d’ailleurs très mal pourquoi elle n’est pas installée par défaut dans Zorin ?
 
0 "J'aime ce message"

Avatar du membre
Mickael
Administrateur
Messages : 1012
Enregistré le : mar. 3 avr. 2018 21:27
Localisation : Ampuis
Nb de « J’aime » donnés: 24
Nb de « J’aime » reçus: 27
A remercié : 7 fois
A été remercié : 19 fois
Contact :
 : Hors ligne

Re: refus d'installer un paquet

Message par Mickael » mar. 7 janv. 2020 08:52

Max77 a écrit :
mar. 7 janv. 2020 08:19
C’est vrai, mais on peut faire la même chose avec Synaptic en s’affranchissant de la ligne de commande que j’aime bien, mais que je n’emploie que contraint et forcé.
Oui, et j'avoue qu'heureusement que vous êtes la pour proposer toute ces solutions sans ligne de commande ... avec des personnes comme moi Linux ferai peur haha

Max77 a écrit :
mar. 7 janv. 2020 08:19
On vante les mérites de Zorin sur ce forum en mettant en avant qu’il se rapproche de la simplicité de Windows pour les commandes, pourquoi ne pas mettre plus en avant cette application très puissante qui permet d‘installer, de désinstaller, de réparer, de mettre à jour et de supprimer les paquets obsolètes ? Mais il est vrai que nous sommes sur le sujet : Utilisation du Terminal !
Les solutions graphiques sont toujours plus simple en effet :)
Moi j'ai trop tendance a utiliser le terminal, surement car j'utilise beaucoup linux en serveur, mais aussi car j'ai Zorin, Debian, Ubuntu mais aussi Mac OS X ... et que le seul point commun sur toutes ces distributions ça reste les lignes de commande ...

Max77 a écrit :
mar. 7 janv. 2020 08:19
​​​​​​​Mais comme dirait l’autre, ne n’est que mon avis :dodgy: .
Ton avis est bon :)

Max77 a écrit :
mar. 7 janv. 2020 08:19
On comprend d’ailleurs très mal pourquoi elle n’est pas installée par défaut dans Zorin ?
Comme je l'avais déjà dit dans un sujet, je pense que ça serai cool de faire un OS maison ... mais c'est un autre sujet ... prendre un ZorinOS 15.1 64 bits lite, et y mettre tout ce qu'on aime et qui est utile et en faire un iso :)
0 "J'aime ce message"
Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.

Avatar du membre
jlb
Modérateur global
Messages : 341
Enregistré le : mer. 11 avr. 2018 08:31
Nb de « J’aime » donnés: 16
Nb de « J’aime » reçus: 53
A remercié : 19 fois
A été remercié : 26 fois
 : Hors ligne

Re: refus d'installer un paquet

Message par jlb » mar. 7 janv. 2020 16:59

Max77 a écrit :
mar. 7 janv. 2020 08:19
On comprend d’ailleurs très mal pourquoi elle n’est pas installée par défaut dans Zorin ?
Ouais, d'autant qu'elle l'est sur des distributions plus sveltes.
Ce que je voulais dire, c'est que malgré les avantages de la windosification des clones d'Ubuntu, j'aime bien de temps à autre pouvoir reprendre la main sur le système sans être pour autant un gourou de la ligne de commande.
​​​​​​​
Mickael a écrit :
mar. 7 janv. 2020 08:52
Comme je l'avais déjà dit dans un sujet, je pense que ça serai cool de faire un OS maison ... mais c'est un autre sujet ... prendre un ZorinOS 15.1 64 bits lite, et y mettre tout ce qu'on aime et qui est utile et en faire un iso :)
N'hésite pas à faire la même chose avec un Zorin 15.1 Lite 3 2bits, je suis preneur ! 

 
1 "J'aime ce message"

Répondre