UEFI : GRUB ne s'affiche pas Le sujet est résolu, aller vers sa solution

Vous rencontrez des problèmes pendant l'installation de Zorin ?
Répondre
Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

UEFI : GRUB ne s'affiche pas

Message par jlb » jeu. 21 janv. 2021 15:13

Bonjour à tous,

Je pensais qu'installer Zorin 15.3 Core "à côté de Windows 10" sur un Acer Aspire V3-572G ne poserait aucun problème, mais ce n'est pas tout à fait le cas.
Zorin et GRUB sont bien installés, mais c'est Windows qui continue à se lancer — cela vaut aussi pour d'autres distributions Ubuntu plus récentes.
Comment faire en sorte que GRUB s'affiche au démarrage ?

J'ai consulté un certain nombre de sites et fait tout autant d'essais, mais je n'ai pas trouvé la réponse, même en réglant la séquence de lancement du BIOS pour que le disque dur passe avant le "Windows Boot Manager".

Certes, rien n'est perdu : par un effet de sérendipité, j'ai même gagné un "système d'exploitation caché", le menu de démarrage d'une clef d'installation d'Ubuntu Budgie (20.04 LTS) proposant une option "Boot from next volume" qui permet d'afficher le menu GRUB, de choisir l'OS à lancer, et donc d'accéder à Linux — ce que Zorin ne propose pas (pas encore ?).
Mais bon, au-delà de la curiosité, ce n'est pas totalement satisfaisant.

En d'autres temps, je me serais obstiné, mais là, désolé, je m'en remets à vous, présumant que je suis un peu "out" sur des technologies plus modernes : avec les ordinosaures, ça rame, on n'a pas Windows 10, mais on n'a pas non plus ce genre de problèmes...

Merci d'avance ! 😷
0 "J'aime ce message"

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 222
Nb de « J’aime » reçus: 39
A remercié : 128 fois
A été remercié : 34 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par roger » jeu. 21 janv. 2021 17:34

Bonjour jlb,

Avant toute chose je te souhaite une bonne année bien que les conditions de vie actuelles ne soient pas des plus réjouissantes.

Je ne pourrais pas te donner un coup de main sur le grub qui ne s'affiche pas au démarrage en ayant installé Zorin sur le même disque dur que Windows car comme toi j'ai eu le même soucis tout en ayant une configuration plus que solide dans mon pc.

J'ai du installer mon Zorin sur un autre disque dur car avec W10 installé et bien le grub ne fonctionnait pas et même si je me rendais dans la config du démarrage OS dans le W10, impossible de mettre dans les gestionnaire de démarrage à l'ouverture de pc Windows en premier et Zorin en second...je pouvais juste paramétrer le temps en secondes avant que Windows se lance sur ma machine.

Je pense que le problème vient en fait de Windows version 10 car avant dans le même pc et avec un W7 + Zorin installé sur le même disque dur, le grub s'affichait correctement en ayant choisi dans le Windows le démarrage de l'ordre de mes os et le temps de X secondes avant qu'il se lance...

Idem en en installant zorin en parallèle avec Windows et bootant ma machine sur le système de zorin, et bien là le grub s'affichait comme je le voulais me proposant le choix entre les deux OS (bien entendu il fallait aussi utiliser le grub customizer en plus pour déclarer le W7 dans le grub zorin).

Par contre je peux te proposer peut être une solution à essayer:

As tu penser à te rendre dans le bios de ta machine et y déclarer le système Ubuntu (c'est ainsi qu'il est nommé pour zorin) comme le système à démarrer sur sa partition partagée avec Windows?

Car si tu arrives à faire cela, et bien ce sera le grub de Zorin qui se lancera en premier au démarrage de ta machine.

Bien amicalement;
Roger
0 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Avatar du membre
Max77
Administrateur
Messages : 196
Enregistré le : lun. 2 déc. 2019 18:01
Localisation : Seine et Marne
Nb de « J’aime » donnés: 8
Nb de « J’aime » reçus: 64
A été remercié : 28 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par Max77 » jeu. 21 janv. 2021 18:01

Bonjour à tous deux par cette nouvelle et merveilleuse année qui commence.

​​​​​​​On avait déjà discuté de cette question, Windows 10 aime bien s’approprier la propriété des disques de l’ensemble de l’ordinateur lorsqu’il est installé.
La solution de roger est bonne, mais je pense que cela ne fonctionne qu’avec un bios "moderne" ;) ​​​​​​​.
 
0 "J'aime ce message"

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par jlb » jeu. 21 janv. 2021 18:13

Bonjour Roger et merci pour ta réponse. Il va de soi que mes meilleurs vœux t'accompagnent  — dans les limites du raisonnable, bien sûr.  😷
roger a écrit :
jeu. 21 janv. 2021 17:34
As tu penser à te rendre dans le bios de ta machine et y déclarer le système Ubuntu (c'est ainsi qu'il est nommé pour zorin) comme le système à démarrer sur sa partition partagée avec Windows?
Pour ce qui est de la solution que tu proposes, il faudrait que le BIOS le permette, ce qui n'est pas le cas, l'ordi en question ayant déjà quelques années (2015 sans doute).

Ce que je trouve étonnant, c'est que l'option "Boot from next volume" du menu d'installation d'Ubuntu me propose de démarrer depuis le disque dur et que ça fonctionne — moyennant huit clics tout de même, le clic de la première photo renvoyant sur l'option de la seconde, qui donne accès au menu du GRUB, mais bon...

1611249649915.jpg

​​​​​​​
1611250311331.jpg

​​​​... alors que le BIOS est réglé pour se lancer depuis le même disque dur et que ça ne fonctionne pas.
 
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
0 "J'aime ce message"

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par jlb » jeu. 21 janv. 2021 18:44

Max77 a écrit :
jeu. 21 janv. 2021 18:01
La solution de roger est bonne, mais je pense que cela ne fonctionne qu’avec un bios "moderne" ;)
Ah là là, @max77, ne me parle pas de modernité !  :-/
 
0 "J'aime ce message"

Avatar du membre
Blind114
Modérateur global
Messages : 108
Enregistré le : lun. 14 sept. 2020 10:51
Localisation : Montpellier / Riorges
Système d'exploitation chez moi : Kali, Zorin, Manjaro, LinuxMint, Windows 7 & 10, Raspbian, Lakka, Q4OS, Parrot Os.
Nb de « J’aime » donnés: 44
Nb de « J’aime » reçus: 34
A remercié : 75 fois
A été remercié : 17 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par Blind114 » ven. 22 janv. 2021 09:26

Salut @jlb,

Tout d'abord, je te souhaite également une excellente année, ainsi qu'à tous les membres de ce forum !

Ensuite, pour avoir moi-même installé à quelques reprises différents OS Linux à côté de windows (7 ou 10), je te confirme que la solution se trouve normalement dans le bios.

Je pense que le plus probable est que grub ne se soit pas parfaitement installé, à cela 2 solutions :
  • réinstaller grub2 (lors de ton install zorin avais-tu créé une micro partition EFI ou /Boot?)
ou
  • simplement réenregistrer toutes les entrées d'OS de grub avec grub-customizer. (c'est cette solution que je privilégierais en premier)
Ensuite effectivement dans ton bios tu peux choisir l'ordre des partitions à solliciter pour le démarrage, et ça devrait fonctionner sans avoir à passer par une clef ou un cd de démarrage.

@+
 
0 "J'aime ce message"
Blind
L'important n'est pas de toujours réussir, mais de toujours comprendre ce qui a foiré et ce qui a fonctionné !

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 222
Nb de « J’aime » reçus: 39
A remercié : 128 fois
A été remercié : 34 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par roger » ven. 22 janv. 2021 09:43

et merde, encore une de mes réponses ou je passe un temps fou à chercher la soluce, les images et quand je poste, pouf tout à disparu!!!! jlb et les amis, pour une fois que je prend le temps de bien tourner les phrase, de me relire etc...comme un con je clique sur une autre onglet (gros défaut quand on en ouvre plusieurs) et ferme celui où je rédigeai ma réponse sans faire gaffe à l'envoyer...

Plus con que Roger tu meurs!!!!

jlb je vais te refaire ma réponse plus tard car là suis trop grrrrmdrarf..... envers moi pour écrire clairement.
Roger
1 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Avatar du membre
Blind114
Modérateur global
Messages : 108
Enregistré le : lun. 14 sept. 2020 10:51
Localisation : Montpellier / Riorges
Système d'exploitation chez moi : Kali, Zorin, Manjaro, LinuxMint, Windows 7 & 10, Raspbian, Lakka, Q4OS, Parrot Os.
Nb de « J’aime » donnés: 44
Nb de « J’aime » reçus: 34
A remercié : 75 fois
A été remercié : 17 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par Blind114 » ven. 22 janv. 2021 10:18

Sans vouloir couper l'herbe sous le pied de @roger,
Encore une chose pour le bios, tu peux aussi supprimer l'option de boot sur ta partoche windows, ça forcera normalement ton bios à booter sur zorin.
@+
0 "J'aime ce message"
Blind
L'important n'est pas de toujours réussir, mais de toujours comprendre ce qui a foiré et ce qui a fonctionné !

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par jlb » ven. 22 janv. 2021 11:24

roger a écrit :
ven. 22 janv. 2021 09:43
encore une de mes réponses ou je passe un temps fou à chercher la soluce, les images et quand je poste, pouf tout à disparu!!!!
Merci pour l'intention, Roger ! Je compatis sincèrement pour avoir éprouvé plusieurs fois pareil désagrément, jusqu'au jour où j'ai renoué avec des pratiques du XXe siècle : un CTRL A + CTRL C systématique avant tout enregistrement. Je ne t'en ai jamais parlé, pensant moi aussi que ça tenait à moi, ou à mon Dellosaure...  😷
0 "J'aime ce message"

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par jlb » ven. 22 janv. 2021 11:52

Bonjour Blind114 et merci pour ton implication.  ;)
 
Blind114 a écrit :
ven. 22 janv. 2021 09:26
Je pense que le plus probable est que grub ne se soit pas parfaitement installé, à cela 2 solutions :
  • réinstaller grub2 (lors de ton install zorin avais-tu créé une micro partition EFI ou /Boot?)
 
Tu en sais plus que moi sur la question...
Je n'ai rien créé de tel : après avoir passé l'ordi de Windows 8.1 à Windows 10, j'ai seulement récupéré l'espace libre et créé une partition ext4 avec GParted avant de lancer l'installation. Le processus l'a détectée et a fait ce qu'il devait faire : j'ai surveillé les détails de l'installation.
GRUB fonctionne en dual boot, les chemins sont bons mais il ne se déclenche pas à l'allumage de l'ordi.

Voici ma configuration, à tout hasard — il y a aussi une partition vide pour de prochains essais :
​​​​​​​
gparted.png

Merci pour les autres suggestions.
A tout hasard, j'ai flashé la dernière version du BIOS disponible (2016), et j'ai relégué Windows boot maganer à la fin du processus. Le plus drôle, c'est que Windows 10 se lance plus rapidement que lorsqu'il était en première position !  :-/

boot.jpg

Je vais essayer de disséquer le GRUB de la clef d'installation de Budgie pour récupérer les paramètres de l'option "Boot from next volume" et les appliquer au GRUB de mon installation.

 
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
0 "J'aime ce message"

Avatar du membre
Blind114
Modérateur global
Messages : 108
Enregistré le : lun. 14 sept. 2020 10:51
Localisation : Montpellier / Riorges
Système d'exploitation chez moi : Kali, Zorin, Manjaro, LinuxMint, Windows 7 & 10, Raspbian, Lakka, Q4OS, Parrot Os.
Nb de « J’aime » donnés: 44
Nb de « J’aime » reçus: 34
A remercié : 75 fois
A été remercié : 17 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par Blind114 » ven. 22 janv. 2021 12:08

@jlb,
sinon, tu peux normalement toujours forcer le boot avec F12 ou le raccourci de ton bios, pour contraindre ton système à y aller.
@ tester, mais je persiste à croire qu'une simple manipulation d'ouverture et d'enregistrement avec grub-customizer pourrait suffire.
En plus, quoiqu'il en soit il n'y a jamais deux install qui se déroulent de la même manière, ce qui m'étonne encore et toujours.
Et à tout hasard dans ton bios tu pourrais nous lister l'intégralité des options que tu as ? Parce que je trouve quand même bizarre qu'avec cette séquence grub de zorin ne démarre pas.
0 "J'aime ce message"
Blind
L'important n'est pas de toujours réussir, mais de toujours comprendre ce qui a foiré et ce qui a fonctionné !

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par jlb » ven. 22 janv. 2021 13:09

Blind114 a écrit :
ven. 22 janv. 2021 12:08
Et à tout hasard dans ton bios tu pourrais nous lister l'intégralité des options que tu as ?
Toutes les options sont sur la photo ci-dessus.
J'ai fait pas mal d'essais censés être concluants. Je ne donne pas les liens parce qu'il faudrait que je reprenne tout sérieusement, pour le cas où le nouveau BIOS aurait réglé les problèmes — ce que je ne crois pas.

J'espère pouvoir en dire plus (très) bientôt.
0 "J'aime ce message"

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par jlb » sam. 23 janv. 2021 20:07

Bon, j'ai fini par trouver une solution fonctionnelle — du moins sur cet ordi, avec cette configuration...

Avec un BIOS "Legacy" (à l'ancienne) on pouvait facilement modifier la séquence d'amorçage avec un petit F2 ou F12 au démarrage. Mais le mode UEFI semble avoir compliqué les choses : ​non seulement la modification depuis F2 ne donne rien, mais depuis un utilitaire comme efibootmgr non plus.

De guère lasse et malgré que j'en eusse, j'ai pris le problème côté Windows puisqu'il y avait fort à parier que c'était lui qui empêchait le GRUB de s'afficher au démarrage...

Oh miracle ! le petit utilitaire EasyUEFI m'a permis de désactiver le Windows Boot Manager et de récupérer le dual boot :

easyuefi.jpg

Quoi qu'il en soit, merci à tous les trois pour vos réponses ! ​​​😷

​​​​​​​
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
1 "J'aime ce message"

Avatar du membre
Blind114
Modérateur global
Messages : 108
Enregistré le : lun. 14 sept. 2020 10:51
Localisation : Montpellier / Riorges
Système d'exploitation chez moi : Kali, Zorin, Manjaro, LinuxMint, Windows 7 & 10, Raspbian, Lakka, Q4OS, Parrot Os.
Nb de « J’aime » donnés: 44
Nb de « J’aime » reçus: 34
A remercié : 75 fois
A été remercié : 17 fois
 : Hors ligne

Re: GRUB ne s'affiche pas

Message par Blind114 » dim. 24 janv. 2021 12:25

Bravo , jolie solution !
0 "J'aime ce message"
Blind
L'important n'est pas de toujours réussir, mais de toujours comprendre ce qui a foiré et ce qui a fonctionné !

Avatar du membre
Max77
Administrateur
Messages : 196
Enregistré le : lun. 2 déc. 2019 18:01
Localisation : Seine et Marne
Nb de « J’aime » donnés: 8
Nb de « J’aime » reçus: 64
A été remercié : 28 fois
 : Hors ligne

Re: UEFI : GRUB ne s'affiche pas

Message par Max77 » dim. 24 janv. 2021 14:44

Ce petit programme a l’air super pratique.

​​​​​​​Mais qu’elle est la limite de la version trial ? Je me pose la question...
 
0 "J'aime ce message"

Avatar du membre
jlb
Administrateur
Messages : 672
Enregistré le : mer. 11 avr. 2018 08:31
Localisation : Hautes-Pyrénées
Nb de « J’aime » donnés: 42
Nb de « J’aime » reçus: 177
A remercié : 49 fois
A été remercié : 85 fois
 : Hors ligne

Re: UEFI : GRUB ne s'affiche pas

Message par jlb » dim. 24 janv. 2021 15:21

Max77 a écrit :
dim. 24 janv. 2021 14:44
​​​​​​​Mais qu’elle est la limite de la version trial ? Je me pose la question...
Ah, ça Max, c'est une question que je me suis jamais posée quand il s'agit d'un usage ponctuel ou d'un dépannage, comme dans le cas présent.
Sinon, RevoUnistaller laisse le registre plutôt propre.
Va-t-il jusqu'à effacer les marqueurs d'installation ? Je ne suis jamais allé plus loin que la question.  😷

@Bilnd114 Si tu le dis... J'avoue que j'aurais préféré trouver une solution Linux.
0 "J'aime ce message"

Répondre