Ecran noir après GRUB sauf si branché à un écran externe

Vous rencontrez des problèmes d'affichage ?
Répondre
Kayndo
Membre
Messages : 4
Enregistré le : dim. 10 mars 2019 16:20
 : Hors ligne

Ecran noir après GRUB sauf si branché à un écran externe

Message par Kayndo » dim. 10 mars 2019 16:43

Bonjour,

Depuis déjà quelques mois, j'ai installé ZorinOs et cette distribution s'avère être ma préférée. Malheureusement, lorsque je lance Zorin juste après le choix d'OS à lancer dans GRUB, mon PC reste bloqué sur un écran noir. J'ai alors essayé de le démarrer en le branchant à un deuxième écran en HDMI et là, bizarrement, le démarrage fonctionne et m'affiche seulement une erreur :

" [Firmware bug]: ACPI region does not cover the entire command/response buffer. [mem 0cfed40000-0xfed4087f flags 0x200] vs fed40080 f80 "

Ensuite, je peux accéder à toutes les fonctionnalités du système d'exploitation comme si de rien n'était et je peux débrancher cette écran.

Je ne comprends pas trop ce que cela signifie, j'ai pas mal cherché d'explications sur le net mais je n'ai trouvé aucune solution à part le fait de devoir brancher mon PC à un deuxième écran afin de contourner cet écran noir. 

J'ai pensé que cela venait peut-être d'un problème de pilotes graphiques mais je sais pas comment y remédier. C'est pour cela que je me tourne vers vous après ces nombreuses recherches sans aucun résultat.

Mon PC est un Médion Akoya S6421 doté d'une Intel® HD 520.

Pouvez-vous m'aider ? Merci de vos réponses.

Bonne journée.
Modifié en dernier par Kayndo le lun. 11 mars 2019 20:37, modifié 1 fois.
0 "J'aime ce message"

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 203
Nb de « J’aime » reçus: 39
A remercié : 115 fois
A été remercié : 34 fois
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par roger » dim. 10 mars 2019 21:48

Kayndo a écrit :J'ai alors essayé de le démarrer en le branchant à un deuxième écran en HDMI
Je travail justement avec un écran HD et mieux c'est carrément un écran de télé.
:idea:   Normalement si tu branches directement (portable arrêté) à ton écran par les branchements hdmi, puis démarre son medion, Zorin à son démarrage devrait le reconnaître de suite.

Tu peux aussi te rendre dans la configuration du zorin os et chercher la la rubrique " Marériel" , tu cliques alors sur affichage et tu devrais avoir ce genre de fenêtre avec le nom de ton écran hdmi dedans.
Image

Je pense que Mickaël pourrait t'en dire plus car il connaît sur le bout des ongles Zorin OS.

Essaies selon mes conseils, et si ça marche super.
0 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Avatar du membre
Mickael
Administrateur
Messages : 1185
Enregistré le : mar. 3 avr. 2018 21:27
Localisation : Coinaud (26)
Nb de « J’aime » donnés: 38
Nb de « J’aime » reçus: 48
A remercié : 7 fois
A été remercié : 38 fois
Contact :
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par Mickael » lun. 11 mars 2019 06:42

Salut à toi.

Peux tu faire un essaie en live CD pour voir si tu as toujours le même problème, ça nous en dira beaucoup plus :)

J'ai trouvé un sujet qui traite un peu du même problème que toi ...
https://ubuntuforums.org/showthread.php?t=2381494
https://forums.fedora-fr.org/viewtopic.php?id=67364
https://askubuntu.com/questions/1007118 ... e-entire-c


De quel année est ton PC ?
Modifié en dernier par Mickael le lun. 11 mars 2019 06:45, modifié 1 fois.
0 "J'aime ce message"
Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 203
Nb de « J’aime » reçus: 39
A remercié : 115 fois
A été remercié : 34 fois
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par roger » lun. 11 mars 2019 09:19

Mickael a écrit :De quel année est ton PC ?
Micka, il est des plus récents, ordi portable écran 15 pouces.

On le trouve ici avec une notice technique tout en bas de la page
https://www.amazon.fr/S6421-MD-60498-39 ... B072QD77F1
Système d'exploitation : Windows 10 Home
Processeur : Intel Core i3-6006u Processeur 2,0 GHz, Mémoire cache 3 Mo)
Fréquence d'horloge : 2.0 Gigahertz
Capacité de la mémoire : 8.0 Gigabyte
Capacité SSD : 256.0 Gigabyte
'Diagonale d'écran : 39,6 cm (15,6)
Résolution : 1366 x 768 pixels
Rétroéclairage LED : OUI
Rapport d'aspect : 16 : 9
Carte Graphique : Intel HD
Son :
Haute définition audio avec 2 haut-parleurs - Dolby certifié Premium
Bluetooth : Bluetooth 4.0
Autre :
multikarte lecteur de cartes mémoire SD/SDHC/SDXC
(cartes mémoire non fournies)
Webcam HD intégrée et micro
Nombre de cellules batterie : 2.0
Interfaces :
multikarte lecteur de cartes mémoire SD, SDHC et SDXC
(cartes mémoire non fournies)
1 x USB 3.0
2 x USB 2.0
1 x HDMI Out
Audio : 1 x audio + (Mic in, Audio out)
WiFi :
LAN sans fil avec fonction Bluetooth 4.0 intégrée
Technologie Quick Wireless LAN IEEE 802.11
0 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Kayndo
Membre
Messages : 4
Enregistré le : dim. 10 mars 2019 16:20
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par Kayndo » lun. 11 mars 2019 15:41

Merci à tous pour vos réponses.

​​​​Malheureusement, un essaie en live CD produit la même erreur. 

Mon PC est en effet récent, voici ses références : https://www.medion.com/be/fr/shop/pc-po ... 653a1.html

Par contre je pense ne pas avoir compris le conseil de roger. En effet je branche mon ordi (éteint) à un écran en hdmi afin de contourner le problème d'écran noir et c'est là que l'erreur s'affiche mais ensuite je peux utiliser Zorin sans problèmes et débranché cet hdmi. 
J'aimerais ne plus avoir à brancher mon portable à un écran pour le démarrer cela est peut pratique si je veux l'utiliser en dehors de chez moi.

Merci pour votre aide.
0 "J'aime ce message"

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 203
Nb de « J’aime » reçus: 39
A remercié : 115 fois
A été remercié : 34 fois
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par roger » lun. 11 mars 2019 17:04

Kayndo a écrit :J'aimerais ne plus avoir à brancher mon portable à un écran pour le démarrer
Rien que cette phrase me fait penser aussitôt à un problème avec ton grub...

Donc copier/coller de ton erreur affichée  l'écran et direct google pour une petite recherche
ACPI region does not cover the entire command/response buffer.
Et j'arrive là: https://www.google.com/search?client=ub ... 8&oe=utf-8

Je clique donc sur la seconde proposition marqué (Solved)

Même intitulé d'erreur et touti... suis donc ce lien (c'est en anglais mais avec google tu as l'option (traduire la page en français)
https://ubuntuforums.org/showthread.php?t=2381494

Le gras a résolu son soucis d'écran noir avec  le conseil d'un membre la bas.
4 réponse en partant du haut et un lien donné dedans suivi par celui qui posait la question, il le remercie en fin de topic car c'était la solution à appliquer.

Donc il faut que tu paramètres ton grub comme pour un acer afin que celui ci reconnaisse ton bios..et donc l'écran de ton portable;

Le HDMI (pour un écran extérieur) lui n'a pas besoin d'être reconnu par le grub (gestionnaire de démarrage) car il ne demande pas de pilote pour fonctionner contrairement à un portable (son bios lance alors tout les matériels (carte mère, priorité de boot etc ) prévus pour utiliser ensuite la machine lors de son démarrage sur une partition d'OS.

Je ne peux t'en dire plus mais je suis certain que ton souci vient de là;
0 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Kayndo
Membre
Messages : 4
Enregistré le : dim. 10 mars 2019 16:20
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par Kayndo » lun. 11 mars 2019 20:42

J'ai essayé cette solution et également celle-ci : https://askubuntu.com/questions/28848/w ... i-linux-do

J'ai également remarqué que mon pc arrive parfois à s'allumer et parfois pas avec cette option : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
0 "J'aime ce message"

Avatar du membre
Mickael
Administrateur
Messages : 1185
Enregistré le : mar. 3 avr. 2018 21:27
Localisation : Coinaud (26)
Nb de « J’aime » donnés: 38
Nb de « J’aime » reçus: 48
A remercié : 7 fois
A été remercié : 38 fois
Contact :
 : Hors ligne

Ecran noir après GRUB sauf si branché à un écran externe

Message par Mickael » lun. 11 mars 2019 21:24

Je pense qu’il faut dans un premier temps essayer de faire la mise à jour de la carte graphique et de ses pilotes, privilégier au maximum les pilotes constructeurs et propriétaires, et si aucun pilote trouver alors essayer des alternatives open source.

Si tout ça ne donne rien alors je pense qu’une mise à jour du bios devrais résoudre le problème ...

Je suis sur mon téléphone portable là donc pas simple, mais dès que je suis devant l’ordinateur je gratte un peu pour chercher des solutions ;)


Envoyé de mon iPhone en utilisant Tapatalk
0 "J'aime ce message"
Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 203
Nb de « J’aime » reçus: 39
A remercié : 115 fois
A été remercié : 34 fois
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par roger » lun. 11 mars 2019 21:32

Kayndo a écrit :J'ai également remarqué que mon pc arrive parfois à s'allumer
de tout ce que j'ai pu lire cet après midi comme doc (sites anglais comme sites allemand car medion était fabriqué chez eux avant que Lenovo ne rachète cette société) il existe beaucoup de problèmes à cause de la carte graphique incorporée dedans Intel HD) qui provoquent des plantages à répétition...
Si ton pc démarre "parfois" c'est bien de ce coté là qu'il te faut chercher une soluce; essaie aussi de voir s'il existe chez Intel des pilotes pour leur carte mais prévus pour Linux ou voir même si tu trouves des pilotes alternatifs (validés bien entendu pour ne pas planter ton pc)...

Au pire, rien ne t'empêches si tu tiens vraiment à ce portable, de l'upgrader vers une carte graphique AMD HD, beaucoup sont compatibles Linux et fournies avec des pilotes adaptés.
0 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Avatar du membre
roger
Administrateur
Messages : 1126
Enregistré le : mer. 4 avr. 2018 15:54
Localisation : Normandie ( Orne )
Système d'exploitation chez moi : Linux Mint Cinamon
Zorin OS 15
LMDE
Windows 10 Pro
Nb de « J’aime » donnés: 203
Nb de « J’aime » reçus: 39
A remercié : 115 fois
A été remercié : 34 fois
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par roger » lun. 11 mars 2019 21:37

oups @"Mickael" , pendant que je rédigeai mon message tu as posté à peu prés les mêmes conseils que moi, je crois que nos avis se rejoignent sur la cause du problème de notre ami.
0 "J'aime ce message"
La science c'est comme la culture :
on la sème, cultive , récolte
(PAS LE POGNON MAIS LE BOULOT !!! )
et surtout on la partage en commun ...

Kayndo
Membre
Messages : 4
Enregistré le : dim. 10 mars 2019 16:20
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par Kayndo » mar. 12 mars 2019 22:00

D'accord, en tout cas merci à vous pour le temps que vous accordez pour chercher des solutions. 

J'ai téléchargé les pilotes et installé les plus récents de mon pc depuis ce lien : https://www.medion.com/be/fr/service/ac ... 3257&gid=1 (depuis Windows) ce qui ne change rien. Par contre, depuis Linux je ne sais pas comment je peux mettre à jour mes pilotes, j'ai essayé avec l'outil pilotes sans fil windows de Zorin mais quand je sélectionne le .inf il me retourne un message d'erreur. 

Bonne soirée.
Modifié en dernier par Kayndo le mar. 12 mars 2019 22:05, modifié 1 fois.
0 "J'aime ce message"

Avatar du membre
Mickael
Administrateur
Messages : 1185
Enregistré le : mar. 3 avr. 2018 21:27
Localisation : Coinaud (26)
Nb de « J’aime » donnés: 38
Nb de « J’aime » reçus: 48
A remercié : 7 fois
A été remercié : 38 fois
Contact :
 : Hors ligne

RE: Ecran noir après GRUB sauf si branché à un écran externe

Message par Mickael » mer. 13 mars 2019 06:49

Essais d'installer tes pilotes en suivant cette procédure pas à pas :
https://doc.ubuntu-fr.org/intel_graphics

J'ai aussi trouver ça : https://askubuntu.com/questions/737840/ ... ics-hd-520
Capture d’écran 2019-03-13 à 06.51.47.png
Si nous traduisons en français cela veux dire :
J'aimerais partager mon expérience avec un problème similaire.

J'ai récemment acheté un ordinateur portable avec le même processeur et je rencontrais des problèmes graphiques. Je dois nécessairement travailler avec Ubuntu 14.04 mais cela ne reconnaissait pas le matériel de mon ordinateur portable (skylake non pris en charge). Je devais installer manuellement le noyau 4.4.6 pour que tout fonctionne correctement. Cependant, j'ai remarqué que compiz prenait plus de 60% du processeur. glxgears a affiché des erreurs telles que: "i965_dri.so ne prend pas en charge l’ID PCI 0x1916" "erreur libGL: ID pci pour fd 4: 8086: 1916, pilote (null)", etc. et dépassement de 300.

La raison en était que les pilotes du GPU n’étaient pas correctement mis à jour, de sorte que le processeur doit faire le travail à sa place. Pour le résoudre, j'ai lancé les commandes suivantes:

Code : Tout sélectionner

 
[code]sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily
[/code]

qui sont installés avec le noyau 4.2.

Après le redémarrage avec le noyau 4.4.6 de mon travail, glxgears affiche les cadrages corrects (environ 60 images par seconde) et la consommation de l’unité centrale est normale.

Je suis un débutant ici mais je suis heureux d'avoir réussi à résoudre ce problème, j'espère que cela sera également utile pour les autres.
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Modifié en dernier par Mickael le mer. 13 mars 2019 06:54, modifié 1 fois.
0 "J'aime ce message"
Tout le monde est un génie. Mais si on juge un poisson sur sa capacité à grimper à un arbre, il passera sa vie à croire qu’il est stupide.

leonidoff22
Membre
Messages : 16
Enregistré le : lun. 2 juil. 2018 10:35
Localisation : Bretagne _ 22
Nb de « J’aime » reçus: 3
A été remercié : 1 fois
 : Hors ligne

Re: Ecran noir après GRUB sauf si branché à un écran externe

Message par leonidoff22 » mar. 23 mars 2021 22:14

Bonsoir,
je viens de survoler ton pb et il ressemble à ce que j'ai déjà connu... à vérifier pour ce qui te concerne.
La solution que j'ai trouvé sur le net est la suivante :
- allume ton ordi et quand tu arrives sur la page de démarrage de Zorin , frappe sur la touche " e " de ton clavier.

... le grub doit s'afficher en mode texte

- repère la ligne dans laquelle est affichée " quiet splash"
- efface "quiet splash" et remplace le par nomodeset xforcevesa ou par nomodeset xmodule=vesa
- appuie sur la touche F10 pour lancer GRUB (il passe alors en mode bavard, toutes les lignes défilent sur l'écran)

Ce changement n'est pas fixé dans ton Grub il agit que sur la connexion présentement lancée.

Si ça fonctionne, il faudra que tu mettes à jour ton Grub soit par Grub-Customizer ou Boot Repair ou encore aller dans le fichier grub en passant par la racine en superutilisateur :  / etc / default / là tu ouvres grub , tu remplaces "quiet splach" comme indiqué plus haut et tu fais une sauvegarde suivi dans le terminal par : sudo update-grub
1 "J'aime ce message"

Répondre